Lens problems

Reviews and questions about new and old equipment.
Share with us your latest purchase or discuss equipment that you are currently using
Post Reply
Message
Author
dean_kos

Lens problems

#1 Post by dean_kos » Mon Dec 30, 2013 11:01 am

image.jpg
image.jpg (196.65 KiB) Viewed 6628 times
Hi all, got this lens for Xmas and I can't seem to achieve focus with it, seems foggy.....
It's brand new just out of box but it's driving me mad any ideas ??

User avatar
DRatledge
Member
Posts: 379
Joined: Mon Oct 12, 2009 8:27 pm
Location: Adlington
Contact:

Re: Lens problems

#2 Post by DRatledge » Mon Dec 30, 2013 2:03 pm

Dean,
It looks like the L series lens (a red line around it) which should be as sharp as they can get. Focus wide open at 105mm should be the easiest to test. However, the foggy bit is worrying. The L series shouldn't get fog/condensation inside them even it has been out in the cold (with Father Christmas) and then brought into central heating inside. My guess would be a seal is faulty and requires returning.

dean_kos

Re: Lens problems

#3 Post by dean_kos » Mon Dec 30, 2013 2:14 pm

Thanks David, I'm struggling getting the bottom cap off also to attach it to camera and the switches on the side seem very tight/stiff...... Think this lens is trouble unless I can suss it and test it properly ....

Amartin

Re: Lens problems

#4 Post by Amartin » Mon Dec 30, 2013 3:53 pm

looks like a nice piece of kit that pal....

User avatar
DRatledge
Member
Posts: 379
Joined: Mon Oct 12, 2009 8:27 pm
Location: Adlington
Contact:

Re: Lens problems

#5 Post by DRatledge » Mon Dec 30, 2013 4:23 pm

Dean,
Some switches on Canon lenses only work when connected to the camera - they require power/activating from the body.

dean_kos

Re: Lens problems

#6 Post by dean_kos » Tue Dec 31, 2013 10:44 am

image.jpg
image.jpg (188.79 KiB) Viewed 6597 times
Sussed it , the fogginess is due to the delicate balance of coffee, sugar and milk .....
Sorry bout that :roll: :D
Could have carried this on for ages but my conscience got the better of me :oops:

User avatar
DRatledge
Member
Posts: 379
Joined: Mon Oct 12, 2009 8:27 pm
Location: Adlington
Contact:

Re: Lens problems

#7 Post by DRatledge » Tue Dec 31, 2013 1:13 pm

Gosh we fell for that one!

Amartin

Re: Lens problems

#8 Post by Amartin » Tue Dec 31, 2013 2:28 pm

:lol:
Should have known better

Post Reply